Home Forums Bullshit Glenn's Weekend Blue 1963 Ragtop

Viewing 0 posts
Viewing 15 posts - 91 through 105 (of 105 total)
  • Author
    Posts
  • Pat K
    Moderator
    Post count: 2221

    ^^^ That won’t cover half of the cost to fix this shit!!!!!!!!!!!

    We will build it if it comes.

    Glennmoss
    Moderator
    Post count: 263

    🤬I am trying to get repair estimates from shops in town.. Hoping this won’t be a fight but it sounds like it will

    John Jones
    Moderator
    Post count: 8542

    dealing with insurance is a bitch…  No good outcome weather you take their estimate or argue with them…  good luck…

    Pat K
    Moderator
    Post count: 2221

    Fixed yet? Get yo money?

    We will build it if it comes.

    Glennmoss
    Moderator
    Post count: 263

    I took it to a shop that Scott from VW Paradise recommended. They just called me this morning with an $11,000 estimate.. haven’t heard back from insurance yet.

    In the meantime, I finessed an Audi rental car out of the deal… because a 1963 VW Bug is basically the same thing right?ECC4E7B3-EDD6-4370-B4D8-561DC5457B17

    Glennmoss
    Moderator
    Post count: 263

    Just got a call back from the insurance adjuster sounds like they’re going to start with repairs at the quoted estimate!

    How would you guys recommend fixing this front quarter panel damage? Is it possible to find a new panel or just body work it out?D22EB2BF-7464-466D-BC80-D0A948597C959C94B4A6-6190-4FCB-B926-9962F74A048C

    Rustabus
    Participant
    Post count: 2420

    Wow! You got Lucky!!!! Insurance paid off!!!  Don’t think you should replace the clip, don’t tell the shop what to do but I think a Port o Power, big rubber sledge hammer, and a measuring tape is the way to start this repair!!!!😀👍😀👍😀😀👍😀👍

    Glennmoss
    Moderator
    Post count: 263

    Thanks Rusty! The shop had asked me haha. I think with all it’s bullshit laws California got one thing right with their car insurance liability. Probably because everyone is obsessed with their cars out here

    alykat
    Participant
    Post count: 702

    Good deal. As a manager at an auto body shop I spent more time trying to get decent response from Insurance Adjusters than any other jobs in the office. Progressive and GEICO were the absolute worst to work with.

    Glennmoss
    Moderator
    Post count: 263

    imageC995669C-6386-4D85-9046-F0A7CEC0142CD3CFBFAD-1EA0-48DB-BFF1-C2D794C40B32B831C807-28A4-40AD-9153-151886A4F6DFGot the bug back and she’s looking great!! They even resprayed the gas tank for me. Now I want to get a new right headlight bucket to match the nice left one.

    Going to get back on the refresh on this. Next on the list was to repaint the roof rack.. do you know what color they would be originally?

    Franz
    Moderator
    Post count: 4508

    imageC995669C-6386-4D85-9046-F0A7CEC0142CD3CFBFAD-1EA0-48DB-BFF1-C2D794C40B32B831C807-28A4-40AD-9153-151886A4F6DFGot the bug back and she’s looking great!! They even resprayed the gas tank for me. Now I want to get a new right headlight bucket to match the nice left one. Going to get back on the refresh on this. Next on the list was to repaint the roof rack.. do you know what color they would be originally?

     

    looking good! Silver paint on the rack.

    Glennmoss
    Moderator
    Post count: 263

    So recently, the bug has been misfiring in a weird way and has been ‘hiccupping’ violently. It will run fine then randomly start to hiccup and backfire before returning to normal. This happens at any speed or throttle input. I tried doing the valves, checking the points, and Will helped me with timing but it still has this issue. Any suggestions on what to do? My best guess would be the points as there was a small bit of buildup on there that I couldn’t sand off but not sure

    tlambert
    Participant
    Post count: 470

    Check for water in the gas tank. This sounds like something I encountered on another type vehicle

    Tim

    Ragtop Ron
    Participant
    Post count: 280

    Looks great Glenn!

    Franz
    Moderator
    Post count: 4508

    Sounds like you’re running out of fuel. Vapor lock?

    Look for the fuel hose too close to the heater box or exhaust. bad fuel pump. Gas tank cap not venting.

    Getting hot? Plugged carb jet?

Viewing 15 posts - 91 through 105 (of 105 total)
  • You must be logged in to reply to this topic.