Glenn's Weekend Blue 1963 Ragtop

//Glenn's Weekend Blue 1963 Ragtop
Glenn's Weekend Blue 1963 Ragtop2017-12-21T16:48:58+00:00

Home Forums Bullshit Glenn's Weekend Blue 1963 Ragtop

Viewing 0 posts
Viewing 15 posts - 16 through 30 (of 33 total)
  • Author
    Posts
  • Rustabus
    Participant
    Post count: 779

    Looks like it has plenty of shine already!!! Why are you still buffing????? 😛  😛  😛  😀

    Glennmoss
    Participant
    Post count: 77

    Just trying to remove as many scratches as possible Rusty

    On that battle, I went a little OCD and took the hood and front fender back down to 2000 grit to try to remove some deeper scratches after already having been finished with the rest of the bug  🙄

    The turn signal had been glued into place  by a previous owner because the holes were too big. When I took it off Rusty and Will helped fill them in

    Nothing like drilling into a fresh paint job  😯

    Kid 63
    Participant
    Post count: 41

    Looking good bro.

     

    Kleake
    Participant
    Post count: 439

    Get after it young man

    Glennmoss
    Participant
    Post count: 77

    More than happy to have my daily driver back in action! There have been a lot of small setbacks that ended up taking longer than expected but I had fun cruising over to Balboa Park this afternoon.IMG_0288[1]IMG_0078[1]IMG_0282

    Scott Sain
    Participant
    Post count: 102

    Looks great! And familiar!

    John Jones
    Keymaster
    Post count: 2998

    RIGHT ON GLENN!!!!!!

    Willy
    Moderator
    Post count: 427

    Bout time! What else did you have to do to it?

    You need to drop that front end a little bit more.

    Jb
    Participant
    Post count: 311

    Pic with the pooch hanging his arm out window is awesome! Car looks great man?

    Glennmoss
    Participant
    Post count: 77

    I have been having some issues with the engine bogging down under acceleration. When I start it up, the alternator light has been coming on but goes away once I give it a little rev.  Also, restarting after some driving requires lots of gas to start the motor. It’s a single port 1600 but think it might be an issue with the centrifugal advance distributor that paradise motorsports replaced the vacuum advance with.

    Franz do you have any suggestions on what I could try?

    John Jones
    Keymaster
    Post count: 2998

    when my points start getting tight… I notice you can’t lug em around as much…

    Glennmoss
    Participant
    Post count: 77

    Cool I’ll try that after this second round of midterms… Did I mention how much I love driving my bug? I get complements on the paint everywhere it goes. IMG_E0325[1]

    Willy
    Moderator
    Post count: 427

    Nice car and great shot! I think thats a Chinese distributor in there from a while back, definitely couldn’t hurt to upgrade it.

    Pat K
    Keymaster
    Post count: 386

    Looking good…?

    You going to help your bro this summer?…hint, hint….HURRY UP!!!!

    Glennmoss
    Participant
    Post count: 77

    I just got an internship with a laser technology company here in SD but I might be able to come out before I start

Viewing 15 posts - 16 through 30 (of 33 total)

You must be logged in to reply to this topic.