50 chevy truck build

User avatar
blitzd
Posts: 213
Joined: Sun May 22, 2005 4:56 pm
Location: DFW Texas

Postby blitzd » Wed Feb 29, 2012 9:26 am

Almost forgot, I hooked up the battery sunday night and saw the front lights lit up for the 1st time ever. When I got it the electrical was hacked so bad nothing worked. Still have not started it yet, but I got the driveshaft in and all the fluids topped off. Need to pick up another ground cable and a new battery this afternoon so I can ground the engine and hopefully hear it run today!

User avatar
blitzd
Posts: 213
Joined: Sun May 22, 2005 4:56 pm
Location: DFW Texas

Postby blitzd » Wed Feb 29, 2012 8:27 pm

Another looong day in the garage. Still working on bedsides, got the tubs finished and most of the dents hammered out. Most of my day was spent on the tubs, I did one side last year but never finished it, and didnt even start the left side. Fabbed the edge for the left bed side and cut out both tubs sides from some 18 gauge. Didn't get to work on the front bed rails today, will finish that tomorrow and get them into epoxy primer.

Image
Image
Image

Its alive!!!! Almost...threw in a new battery and grounded the block and cab to the frame but it wont start. I messed with it for about an hour and got frustrated. Not sure if it is the starter or the switch yet. I also have an electrical problem, dunno if it is the column or what but when the column is plugged in the hazards flash. Other than that everything works fine. Was hoping for a 1st drive tonight...oh well. Feels good to see lights working!

Image

User avatar
blitzd
Posts: 213
Joined: Sun May 22, 2005 4:56 pm
Location: DFW Texas

Postby blitzd » Wed Feb 29, 2012 8:49 pm

Lot of work done this month thanks to the build off! This kept me motivated as hell. Thanks KCW!

Here is a list of what got done this month.

Sanded and painted hood (final paint, painted it twice last month)
Sanded cab, fixed some of my crappy body work
painted cab
mounted front clip
Mounted bumper, fabbed brackets for it
Wired most of the truck
Extended rear frame, boxed and drilled speed holes
Installed air ride compressor, tank, and mounted battery
Installed gas tank and seat
Installed steering column, fabbed bracket for it, setup steering linkage
Body worked bed, shaved gate hooks all holes and finished tubs
Fixed and body worked rusty running boards
Body worked and primed interior trim
Altered and mounted running board brackets, mounted running boards
Body worked and filled holes in both rear fenders
Mounted shocks
Installed audio system (works great! no stereo just IPOD to amp)
Driveshaft u joint fiasco solved and driveshaft installed
Cowl vent rebuilt, detailed, installed
Exhaust final welded, hangers installed

User avatar
blitzd
Posts: 213
Joined: Sun May 22, 2005 4:56 pm
Location: DFW Texas

Postby blitzd » Thu Mar 01, 2012 6:22 pm

Well im freaking tired from thrashing the past few nights but im a man on a mission and the show must go on!

Figured out my wiring problems from yesterday, bad ground at the block and the flashers was just me being an idiot. All wiring works fine now. While I was wiring I started mounting the air valves and ran wires for them. Double checked all the engine stuff and it looks like im good to go for 1st start up but ill save that for tomorrow when I can get someone over here to help me set the timing, break in the cam, and make sure I dont catch myself on fire! lol.
Joey

User avatar
el arod
Posts: 360
Joined: Wed Feb 03, 2010 2:14 pm
Location: The Dirty South, MIAMI.

Postby el arod » Thu Mar 01, 2012 8:27 pm

damn i love the look of that front end =P~
alex
"Trailer?" "Those are for boats!"

User avatar
blitzd
Posts: 213
Joined: Sun May 22, 2005 4:56 pm
Location: DFW Texas

Postby blitzd » Sat Mar 03, 2012 1:42 pm

blitzd wrote: and make sure I dont catch myself on fire! lol.


Gonna wrap up as much as I can this afternoon then this thing will most likely be going back on the back burner for a few months. Thanks to the build off for getting me so far along this month. I got a lot of things accomplished this month.
Joey

User avatar
blitzd
Posts: 213
Joined: Sun May 22, 2005 4:56 pm
Location: DFW Texas

Postby blitzd » Tue Mar 06, 2012 8:45 am

Been busy the last few days around the house, last night I messed with the truck a little and fired it up and drove it around. Runs good, still needs some tuning but that will have to wait. The idle sounds nice with this cam. I cant wait to put some miles on it.

Truck wont get much love for a while, this is my busy season at work and ive been dispatched Nashville area for a month or so.
Joey

User avatar
tylorDURBEN
Posts: 704
Joined: Mon May 02, 2005 7:59 pm
Location: Hialeah, Fl

Postby tylorDURBEN » Wed Jun 20, 2012 10:05 am

have you made any more progress on the truck? we are putting in time for the next 2 weeks on my buddies truck and yours provides some great motivation would love to see more!


Return to “2012 build-offs”

Who is online

Users browsing this forum: No registered users and 1 guest