Carburetor question

//Carburetor question
Carburetor question 2017-10-08T18:26:45+00:00

Home Forums Technical Questions Carburetor question

Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
    Posts
  • Volksman
    Participant
    Post count: 20

    I got the carb back on Friday from Tim @ Volkzbitz. He did an outstanding job on rebuilding the carb:

     

    I installed in on Saturday and it did make quite a difference. The bug started up easily after getting fuel to the carb and then seemed to run much smoother. However, this is not the only issue. I was able to drive the car but it really had no decent power or acceleration. When I rev the engine up it feels like it is bogging out at the top. I kind of figured something else would be an issue as I mentioned above so now I think I need to look at the points and timing. I had checked the points previously as I also mentioned above but I haven’t messed with the timing. A friend suggested getting an electronic points kit to put in the distributor. I have no idea if that is a good idea or not. What do you guys think? Bear in mind this is a stock 40hp 6volt car.

    I guess I  need to get my towbar out and haul this think over to KCW. I just need to convince my wife that it is absolutely necessary. 🙂

     

     

    Franz
    Keymaster
    Post count: 336

    Torque the heads & adjust valves?

    Maybe run a compression test.

    I would keep the points system.

     

    But yeah, haul it over here if you want. I’ll work on it.

    Jdawg
    Participant
    Post count: 287

    Well I don’t know much but I had a pointless ignition in my car when I dropped it off at KCW, Franz found that it was malfunctioning and it has points again…I had other ailments causing my “runs like shit” issue but that was one of the big ones. If I was you, I would take the car to KCW regardless of what the wife says…its easier to ask for forgiveness then deal with a VW that runs like shit!  😛  BTW the carb looks awesome.

    Volksman
    Participant
    Post count: 20

    Thanks for the fast replies! I did adjust the valves prior to firing up the engine so I think they are ok. I did not check the torque on the heads or the compression. Out of curiosity Franz – what is the labor rate for mechanical work? It would probably be a lot better overall for me to just bring this to you and have you fix all the weird performance  issues. I expected stuff like this since the car sat for so long before I got it. I just wish I had the knowledge to make it work right.

     

    Yeah JDawg I have done the ask forgiveness thing before. In fact when I got this bug I had to pull the trigger super fast because the guy was waffling on selling it to me. So…on my daughter’s birthday I had to slip out with a buddy and a car hauler and then come back. She was a little bit unhappy with me. 🙂 But I didn’t want to miss out on getting the car.

    JWDII
    Participant
    Post count: 119

    Carb looks great man, Sorry to here that wasn’t the cure all! Glad to see Tim did a good job! Like others said I would just haul it to KCW. I would be there already if it wasn’t 1800 miles one way. It requires a little more planning for me!

Viewing 5 posts - 16 through 20 (of 20 total)

You must be logged in to reply to this topic.